Excerpt from Intel Mash Maker's web site:

Technical Requirements

  • FireFox 2.0 or later
    • We intend to produce Internet Explorer and Safari versions later.

Firefox, the lead browser for cool extensions... Other browsers later :-)