Because of the fix for bug 292789, the webchunks extension was completely horking Firefox 3. Hence the need for webchunks 0.12.2. Auto-updates are also enabled now.