1. get the following email from addons.mozilla.org:
  2. We've noticed that Glazoom is a very popular add-on which is not yet compatible
    with Firefox 3.1. We'd like to update you on our progress with Firefox 3.1, as
    well as provide some help and resources to make the transition as painless as
    possible.

    (...)

    We ask that you please check your add-on for compatibility with the latest beta,
    and if everything looks good, bump your maxVer on addons.mozilla.org (AMO) to
    "3.1b3".

    (...)
  3. udpate extension as suggested bumping maxVersion to 3.1b3
  4. submit it to addons.mozilla.org
  5. get the following error message:
    The following errors were found in install.rdf:
    3.1b3 is not a valid version for Firefox